Docpad Heroku Deployment Errors (postinstall)

24000 info install [email protected]

24001 info postinstall [email protected]

24002 verbose unsafe-perm in lifecycle true

24003 info [email protected] Failed to exec postinstall script

24004 error [email protected] postinstall: `node node_modules/bower/bin/bower install`

24004 error Exit status 8

24005 error Failed at the [email protected] postinstall script.

24005 error This is most likely a problem with the twitter-bootstrap.docpad package,

24005 error not with npm itself.

24005 error Tell the author that this fails on your system:

24005 error     node node_modules/bower/bin/bower install

24005 error You can get their info via:

24005 error     npm owner ls twitter-bootstrap.docpad

24005 error There is likely additional logging output above.

24006 error System Linux 3.8.11-ec2

24007 error command "/tmp/build_7e3a8d28-b8ef-4409-b27b-00489d37d659/vendor/node/bin/node" "/tmp/build_7e3a8d28-b8ef-4409-b27b-00489d37d659/vendor/node/bin/npm" "install" "--userconfig" "/tmp/build_7e3a8d28-b8ef-4409-b27b-00489d37d659/.npmrc" "--production"

24008 error cwd /tmp/build_7e3a8d28-b8ef-4409-b27b-00489d37d659

24009 error node -v v0.10.28

24010 error npm -v 1.4.9

24011 error code ELIFECYCLE

24012 verbose exit [ 1, true ]

Docpad 6.65.0 using twitter-bootstrap-jade skeleton.

Fix:

in package.json, add:

   "bower": "~1"

to dependencies.

It will already be present in devDependencies, however is missing from dependencies.

Pull request created.